Home Şəbəkə Arista EOS CLI komandaları

Arista EOS CLI komandaları

191
0

Sistemə giriş Cisco-da olduğu kimidir.

switch> enable
switch# configure
switch(config)#
veos> enable
veos# bash

burada əlavə digər əmr də işləyir

show version

show inventory

kimlik təsdigləmə

username admin secret XXXXXX
The SFP-1G-T transceivers advertise one speed at a time only. Hence, the desired speed and negotiation must be configured explicitly using the following commands:
•speed auto: auto-negotiated 1Gbps (this is because no speed is specified and we are defaulting to advertise 1G).
•speed auto 1G full/ speed 1G: auto-negotiated 1Gbps (note that per BASE-T standard, 1G must be negotiated)
•speed auto 100full: auto-negotiated 100Mbps
•speed 100full: non-negotiated/true-forced 100Mbps

Port Channel

switch(config)#interface ethernet 1-2
switch(config-if-Et1-2)#channel-group 10 mode active
switch(config-if-Et1-2)#show active

VLAN

switch(config)#vlan 45
switch(config-vlan-45)#

Access Ports

switch(config)#interface ethernet 5
switch(config-if-Et5)#switchport access vlan 15
switch(config-if-Et5)#

Trunk Ports

switch(config)#interface ethernet 12-16
switch(config-if-Et12-16)#switchport trunk allowed vlan 15,20-22,40,75
switch(config-if-Et12-16)#
switch(config)#interface ethernet 14
switch(config-if-Et14)#switchport trunk allowed vlan add 100-120
switch(config-if-Et14)#

NAT

7150S#show ip nat translation static
Source IP       Destination IP       Translated IP         TGT Type Intf
----------------------------------------------------------------------------
10.0.0.15:0       -                     20.0.0.15:0           SRC STAT Et6

Source NAT

Bu əmrlər qaynaq İP ünvanı 10.24.1.10-dan 168.32.14.15-ə çevirmək üçün VLAN 201-i konfiqurasiya edir.

switch(config)#interface vlan 201
switch(config-if-Vl201)#ip nat source static 10.24.1.10 168.32.14.15
switch(config-if-Vl201)#

VRF

sh vrf
sh ip route vrf vrf1
ping vrf vrf2 192.168.204.1
vrf definition vrf1
   rd 65000:1

vrf definition vrf2
   rd 65000:2

interface Vlan301
   vrf forwarding vrf1
   ip address 30.0.1.254/24

interface Vlan401
   vrf forwarding vrf2
   ip address 40.0.1.254/24


ip route vrf vrf1 40.0.1.0/24 30.0.2.1
ip route vrf vrf2 30.0.1.0/24 40.0.12.1


ip routing
ip routing vrf vrf1
ip routing vrf vrf2

LLDP

# show lldb
# no lldp run   <- Disable LLDP

Spanning-tree

# no spanning-tree 1-4097

IPv4 Multicast Routing aktiv etmək

ip routing
ip multicast-routing

interface Ethernet1
   ip pim sparse-mode

ip pim rp-address 172.16.1.254

ip route 172.16.2.0/24 172.16.1.254
switch(config)#router multicast
switch(config-router-multicast)#ipv4
switch(config-router-multicast-ipv4)#routing

Enables PIM and IGMP on VLAN interface.

Allie(config-if-vl20)#interface vlan 21
Allie(config-if-vl21)#pim ipv4 sparse-mode
Allie(config-if-vl21)#interface vlan 24
Allie(config-if-vl24)#pim ipv4 sparse-mode
Allie(config-if-vl24)#interface vlan 10
Allie(config-if-vl10)#pim ipv4 sparse-mode
Allie(config)#router multicast
Allie(config-router-multicast)#ipv4
Allie(config-router-multicast-ipv4)#routing
Allie(config-router-multicast-ipv4)#activity polling-interval 5
Allie(config-router-multicast-ipv4)#router pim sparse-mode
Allie(config-router-pim-sparse)#ipv4
Allie(config-router-pim-sparse-ipv4)#rp address 10.25.10.15

Clock(PTP)

switch(config)#clock timezone US/Central
switch(config)#show clock
Mon Jan 14 18:42:49 2013
timezone is US/Central

TimeStamp Configuration Examples

switch(config)#interface ethernet 44
switch(config-if-Et44)#mac timestamp before-fcs
switch(config-if-Et44)#show active
interface Ethernet44
   mac timestamp before-fcs
switch(config-if-Et44)#
switch(config-if-Et44)#no mac timestamp
switch(config-if-Et44)#show active
interface Ethernet44
switch(config-if-Et44)#

PTP Configuration Examples

Global Configuration

localhost(config)#ptp mode boundary
localhost(config)#ptp domain 127     (or other value, which must match the domain on the GM)
localhost(config)#ptp source ip <ip address>    (create a Loopback address and define this as the source IP - thereby a unique IP address of the system matches the PTP Source IP)
localhost(config)#ptp ttl 32   (or other value, default is 1)

Slave (Per Interface Connected to a Non-Slave Device)

On interface level, L2 or L3, or port-channel,

localhost(config-if-Et1)#ptp enable
localhost(config-if-Et1)#ptp announce interval 0
localhost(config-if-Et1)#ptp sync interval -3
localhost(config-if-Et1)#ptp delay-req interval -3

Master (Per Interface Connected to a Slave Device)

localhost(config-if-Et1)#ptp enable
localhost(config-if-Et1)#ptp announce interval 0
localhost(config-if-Et1)#ptp sync interval -3
localhost(config-if-Et1)#ptp delay-req interval -3
localhost(config-if-Et1)#ptp role master

show ptp

switch#show ptp
PTP Mode: gptp - Generalized PTP Clock
Clock Identity: 2001:0DB8:73:ff:ff:26:fd:90
Grandmaster Clock Identity: 2001:0DB8:96:ff:fe:6c:ed:02
Number of slave ports: 1
Number of master ports: 6
Slave port: Ethernet33
Mean Path Delay (nanoseconds): 718
Steps Removed: 1
Neighbor Rate Ratio: 1.00000007883
Rate Ratio: 1.00000007883
Interface State    AS      Time Since Last    Neighbor    Mean Path   Residence
                   Capable Changed            Rate Ratio  Delay (ns)  Time (ms)
--------- -------- ------- ------------------ ----------- ----------- ---------
Et1       Disabled No      Never              1.0         0           0
Et2       Disabled No      Never              1.0         0           0
Et3       Disabled No      Never              1.0         0           0
Et4       Disabled No      Never              1.0         0           0
Et5       Disabled No      Never              1.0         0           0
Et6       Disabled No      Never              1.0         0           0
Et7       Master   Yes     0:21:08            1.00000009  420         0
<-------OUTPUT OMITTED FROM EXAMPLE--------> 

show ptp masters (show ptp parent)

show ptp masters
show ptp parent

show ptp local-clock (show ptp clock)

show ptp local-clock
show ptp clock

show ptp interface

switch# show ptp interface
Interface Ethernet1
PTP: Disabled
Port state: Disabled
Sync interval: 1.0 seconds
Announce interval: 2.0 seconds
Announce interval timeout multiplier: 3
Delay mechanism: end to end
Delay request message interval: 32.0 seconds
Transport mode: ipv4
 
Interface Ethernet5
PTP: Disabled
Port state: Disabled
Sync interval: 8.0 seconds
Announce interval: 2.0 seconds
Announce interval timeout multiplier: 5
Delay mechanism: peer to peer
Peer delay request message interval: 8.0 seconds
Peer Mean Path Delay: 0
Transport mode: ipv4
<-------OUTPUT OMITTED FROM EXAMPLE--------> 
switch#

show ptp interface ethernet

show ptp interface ethernet 3

show ptp monitor

Switch# show ptp monitor
PTP Mode: Boundary Clock
Ptp monitoring: enabled
Number of entries: 5
Offset from master threshold: 1500
Mean path delay threshold: not configured
Skew threshold: 0.5
Interface  Time                          Offset from   Mean Path    Skew
                                         Master (ns)   Delay (ns)
---------- ----------------------------- ------------ ------------- -----------
Et8        21:23:12.901 UTC Feb 22 2018  71            5849         1.003159918
Et1        21:23:12.901 UTC Feb 22 2018  113           3672         1.004990621
Et2        21:23:12.901 UTC Feb 22 2018  706           7799         1.002744199
Et1        21:23:12.901 UTC Feb 22 2018  803           5861         1.003432049
Et1        21:23:12.901 UTC Feb 22 2018  610           3415         0.998974658

Previous articleROBOCOPY- robocopy komandalarını Windows sistemində çalışdırma
Next articleAvtomatik akumulyator şarj edici dövrəsi

LEAVE A REPLY

Please enter your comment!
Please enter your name here